aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMacroFake <falke.marco@gmail.com>2022-06-08 17:20:12 +0200
committerMacroFake <falke.marco@gmail.com>2022-06-08 17:20:15 +0200
commit2e079c86aefd3b7a1a4ad54bb38cc3f53fca8c1a (patch)
treeaea99247038994af3670063f9aa68c63e60c5ff1 /configure.ac
parentb9416c3847cd347238a9d75d949327f69e187d79 (diff)
parent06e18e0b53ed34933ecd7f3976a508be72f687aa (diff)
downloadbitcoin-2e079c86aefd3b7a1a4ad54bb38cc3f53fca8c1a.tar.xz
Merge bitcoin/bitcoin#24395: build: use `BOOST_MULTI_INDEX_ENABLE_SAFE_MODE` when debugging
06e18e0b53ed34933ecd7f3976a508be72f687aa build: use BOOST_MULTI_INDEX_ENABLE_SAFE_MODE when debugging (fanquake) Pull request description: Use of this macro enables precondition checks for iterators and functions of the library. It's use is recommended in debug builds. See https://www.boost.org/doc/libs/1_78_0/libs/multi_index/doc/tutorial/debug.html for more info. There is also a `BOOST_MULTI_INDEX_ENABLE_INVARIANT_CHECKING` macro: > When this mode is in effect, all public functions of Boost.MultiIndex will perform post-execution tests aimed at ensuring that the basic internal invariants of the data structures managed are preserved. ACKs for top commit: laanwj: Concept and code review ACK 06e18e0b53ed34933ecd7f3976a508be72f687aa Tree-SHA512: 7ee489eccda81c7dbca9210af6d3007d5b2c704b645139d2714c077af157789dd9478c29d0d212e210e96686ea83713aaf3d458e879122b3cde64f3e3e3789d2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e09ef14156..f6d00d0283 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1454,6 +1454,10 @@ if test "$use_boost" = "yes"; then
dnl we don't use multi_index serialization
BOOST_CPPFLAGS="$BOOST_CPPFLAGS -DBOOST_MULTI_INDEX_DISABLE_SERIALIZATION"
+ if test "$enable_debug" = "yes" || test "$enable_fuzz" = "yes"; then
+ BOOST_CPPFLAGS="$BOOST_CPPFLAGS -DBOOST_MULTI_INDEX_ENABLE_SAFE_MODE"
+ fi
+
if test "$suppress_external_warnings" != "no"; then
BOOST_CPPFLAGS=SUPPRESS_WARNINGS($BOOST_CPPFLAGS)
fi