aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2021-02-04 13:14:17 +0100
committerMarcoFalke <falke.marco@gmail.com>2021-02-04 13:11:57 +0100
commitfac4be30482c21ac330e09ef8756c49e37faa6fa (patch)
tree0f9c5c3b4a17f0de0ca7a391c374974ba1123b01 /configure.ac
parentea5a50f92a6ff81b1d2dd67cdc3663e0e66733ac (diff)
downloadbitcoin-fac4be30482c21ac330e09ef8756c49e37faa6fa.tar.xz
fuzz: Configure check for main function (take 2)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dca4c5edd8..c16eae8ba1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1254,8 +1254,10 @@ if test "x$enable_fuzz" = "xyes"; then
#include <cstdint>
#include <cstddef>
extern "C" int LLVMFuzzerTestOneInput(const uint8_t *data, size_t size) { return 0; }
- /* unterminated comment to remove the main function ...
- ]],[[]])])
+ /* comment to remove the main function ...
+ ]],[[
+ */ int not_main() {
+ ]])])
else
BITCOIN_QT_INIT