aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-09-04 17:58:10 +0100
committerfanquake <fanquake@gmail.com>2022-09-04 17:58:10 +0100
commite531e34b4146792fb61e178c5a1370ab223e9c3a (patch)
tree7b5c7ed77576245dabf3ea9800e4862a9cea4c15 /configure.ac
parent604015ac7955695209dd6405db2c595e60e135b3 (diff)
downloadbitcoin-e531e34b4146792fb61e178c5a1370ab223e9c3a.tar.xz
build: fix configuring with --without-experimental-kernel-lib
Fixes #25994.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1752fda344..1405adf702 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1695,11 +1695,12 @@ AM_CONDITIONAL([BUILD_BITCOIN_UTIL], [test $build_bitcoin_util = "yes"])
AC_MSG_RESULT($build_bitcoin_util)
AC_MSG_CHECKING([whether to build experimental bitcoin-chainstate])
-if test "$build_experimental_kernel_lib" = "no"; then
-AC_MSG_ERROR([experimental bitcoin-chainstate cannot be built without the experimental bitcoinkernel library. Use --with-experimental-kernel-lib]);
-else
- AM_CONDITIONAL([BUILD_BITCOIN_CHAINSTATE], [test $build_bitcoin_chainstate = "yes"])
+if test "$build_bitcoin_chainstate" = "yes"; then
+ if test "$build_experimental_kernel_lib" = "no"; then
+ AC_MSG_ERROR([experimental bitcoin-chainstate cannot be built without the experimental bitcoinkernel library. Use --with-experimental-kernel-lib]);
+ fi
fi
+AM_CONDITIONAL([BUILD_BITCOIN_CHAINSTATE], [test $build_bitcoin_chainstate = "yes"])
AC_MSG_RESULT($build_bitcoin_chainstate)
AC_MSG_CHECKING([whether to build libraries])