aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-07-23 23:31:01 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-07-27 10:07:34 +0100
commitb9f06bf05b67239cea80998a747f73a2ed3e7be6 (patch)
tree2668ca9df000c4d01c2291dafc497980764a4570 /configure.ac
parent194f6dc43ccc330a8a4607be3a2b8935490d6db0 (diff)
downloadbitcoin-b9f06bf05b67239cea80998a747f73a2ed3e7be6.tar.xz
build: Do not export `PKG_CONFIG_{PATH|LIBDIR}` variables
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90e7f18515..924bfd35ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,16 @@ if test "$PKG_CONFIG" = ""; then
AC_MSG_ERROR([pkg-config not found])
fi
+# When compiling with depends, the `PKG_CONFIG_PATH` and `PKG_CONFIG_LIBDIR` variables,
+# being set in a `config.site` file, are not exported to let the `--config-cache` option
+# work properly.
+if test -n "$PKG_CONFIG_PATH"; then
+ PKG_CONFIG="env PKG_CONFIG_PATH=$PKG_CONFIG_PATH $PKG_CONFIG"
+fi
+if test -n "$PKG_CONFIG_LIBDIR"; then
+ PKG_CONFIG="env PKG_CONFIG_LIBDIR=$PKG_CONFIG_LIBDIR $PKG_CONFIG"
+fi
+
BITCOIN_DAEMON_NAME=bitcoind
BITCOIN_GUI_NAME=bitcoin-qt
BITCOIN_CLI_NAME=bitcoin-cli