aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-03-02 18:59:05 +0200
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-03-02 19:07:31 +0200
commita4128138b4837baadde75247cd4fd8ea463b7df5 (patch)
tree1a793853e6a47d7b800f11fd9de1b0061a301bf8 /configure.ac
parent9fef2099452a21335db38d66c04baec69cbc36ee (diff)
downloadbitcoin-a4128138b4837baadde75247cd4fd8ea463b7df5.tar.xz
build: Make AM_CONDITIONAL([ENABLE_EXTERNAL_SIGNER]) unconditional
This change fixes an error when the value of the "use_boost" variable is equal to "no".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index edbfdc0688..c5bc7ebc7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1406,8 +1406,6 @@ if test x$use_boost = xyes; then
)
fi
- AM_CONDITIONAL([ENABLE_EXTERNAL_SIGNER], [test "x$use_external_signer" = "xyes"])
-
if test x$suppress_external_warnings != xno; then
BOOST_CPPFLAGS=SUPPRESS_WARNINGS($BOOST_CPPFLAGS)
fi
@@ -1420,6 +1418,8 @@ if test x$use_boost = xyes; then
BOOST_LIBS="$BOOST_LDFLAGS $BOOST_SYSTEM_LIB $BOOST_FILESYSTEM_LIB"
fi
+AM_CONDITIONAL([ENABLE_EXTERNAL_SIGNER], [test "x$use_external_signer" = "xyes"])
+
dnl Check for reduced exports
if test x$use_reduce_exports = xyes; then
AX_CHECK_COMPILE_FLAG([-fvisibility=hidden],[CXXFLAGS="$CXXFLAGS -fvisibility=hidden"],