aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2022-03-21 23:52:35 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2022-03-21 23:54:50 +0000
commit556ee6f2fa0e2da2bb12fe05a885431f61db2e47 (patch)
tree20af5c5c4f61c9b2401da593b4ecfcd36ba2bace /configure.ac
parent831675c8dccfa6525ffe751da3cc60709c380953 (diff)
downloadbitcoin-556ee6f2fa0e2da2bb12fe05a885431f61db2e47.tar.xz
Bugfix: configure: Quote SUPPRESS_WARNINGS sufficiently to preserve brackets
The regex includes [/ ] which is supposed to match either a forward slash or a space, but m4 treats the brackets as special characters and effectively strips them out, leading to -isystem /usr/include paths except for in the typical scenario where it is the final parameter in the flag string.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9a16b7c880..db283347cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1175,7 +1175,7 @@ dnl Do not change "-I/usr/include" to "-isystem /usr/include" because that
dnl is not necessary (/usr/include is already a system directory) and because
dnl it would break GCC's #include_next.
AC_DEFUN([SUPPRESS_WARNINGS],
- [$(echo $1 |${SED} -E -e 's/(^| )-I/\1-isystem /g' -e 's;-isystem /usr/include([/ ]|$);-I/usr/include\1;g')])
+ [[$(echo $1 |${SED} -E -e 's/(^| )-I/\1-isystem /g' -e 's;-isystem /usr/include([/ ]|$);-I/usr/include\1;g')]])
dnl enable-fuzz should disable all other targets
if test "x$enable_fuzz" = "xyes"; then