aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-01-13 21:07:44 +0800
committerfanquake <fanquake@gmail.com>2022-01-15 10:02:04 +0800
commite2ab9f83f8655bf09ea392beeee36b2bbe29769b (patch)
treecc33ec945f3e73bf91190dd61ccad13cb4e6ccb2 /configure.ac
parent807169e10b4a18324356ed6ee4d69587b96a7c70 (diff)
downloadbitcoin-e2ab9f83f8655bf09ea392beeee36b2bbe29769b.tar.xz
build: disable external signer on Windows
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5a6b54a1ae..bef3973996 100644
--- a/configure.ac
+++ b/configure.ac
@@ -321,7 +321,7 @@ AC_ARG_ENABLE([werror],
AC_ARG_ENABLE([external-signer],
[AS_HELP_STRING([--enable-external-signer],[compile external signer support (default is yes, requires Boost::Process)])],
[use_external_signer=$enableval],
- [use_external_signer=yes])
+ [use_external_signer=auto])
AC_ARG_ENABLE([lto],
[AS_HELP_STRING([--enable-lto],[build using LTO (default is no)])],
@@ -1415,7 +1415,21 @@ if test "$use_boost" = "yes"; then
fi
if test "$use_external_signer" != "no"; then
- AC_DEFINE([ENABLE_EXTERNAL_SIGNER], [], [Define if external signer support is enabled])
+ case $host in
+ *mingw*)
+ dnl Boost Process uses Boost Filesystem when targeting Windows. Also,
+ dnl since Boost 1.71.0, Process does not work with mingw-w64 without
+ dnl workarounds. See 67669ab425b52a2b6be3d2f3b3b7e3939b676a2c.
+ if test "$use_external_signer" = "yes"; then
+ AC_MSG_ERROR([External signing is not supported on Windows])
+ fi
+ use_external_signer="no";
+ ;;
+ *)
+ use_external_signer="yes"
+ AC_DEFINE([ENABLE_EXTERNAL_SIGNER], [1], [Define if external signer support is enabled])
+ ;;
+ esac
fi
AM_CONDITIONAL([ENABLE_EXTERNAL_SIGNER], [test "$use_external_signer" = "yes"])