aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2021-03-02 17:19:03 -0500
committerfanquake <fanquake@gmail.com>2021-07-07 19:31:37 +0800
commita8127b34bce3597b8091e14057c926197966a234 (patch)
tree5229c1de235d6c103a5f6908171bddc90a4bd55c /configure.ac
parent678348db515c770c4dddfac512cdd97be11d407d (diff)
downloadbitcoin-a8127b34bce3597b8091e14057c926197966a234.tar.xz
build: Use and test PE binutils with --reloc-section
Also fix test-security-check.py to account for new PE PIE failure indication.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 94f01a51a6..6f78e8dec4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -900,6 +900,7 @@ if test x$use_hardening != xno; then
])
fi
+ AX_CHECK_LINK_FLAG([[-Wl,--enable-reloc-section]], [HARDENED_LDFLAGS="$HARDENED_LDFLAGS -Wl,--enable-reloc-section"],, [[$LDFLAG_WERROR]])
AX_CHECK_LINK_FLAG([[-Wl,--dynamicbase]], [HARDENED_LDFLAGS="$HARDENED_LDFLAGS -Wl,--dynamicbase"],, [[$LDFLAG_WERROR]])
AX_CHECK_LINK_FLAG([[-Wl,--nxcompat]], [HARDENED_LDFLAGS="$HARDENED_LDFLAGS -Wl,--nxcompat"],, [[$LDFLAG_WERROR]])
AX_CHECK_LINK_FLAG([[-Wl,--high-entropy-va]], [HARDENED_LDFLAGS="$HARDENED_LDFLAGS -Wl,--high-entropy-va"],, [[$LDFLAG_WERROR]])