aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-02-14 20:20:21 +0000
committerfanquake <fanquake@gmail.com>2022-02-14 20:21:10 +0000
commit988058defbb654c256c0e48d7489e19975060c5f (patch)
tree7a51e97cafb889555a47da4383109db2f0cd0c9b /configure.ac
parent9011d4d8ae610d75f12a36aabf6c5ea6f97a8840 (diff)
parentabc057c6030b2a0ddab46835a7801054da677781 (diff)
downloadbitcoin-988058defbb654c256c0e48d7489e19975060c5f.tar.xz
Merge bitcoin/bitcoin#24254: build: Add Boost.Process usage check
abc057c6030b2a0ddab46835a7801054da677781 build: Add Boost.Process usage check (Hennadii Stepanov) Pull request description: This PR adds a check that Boost.Process can be used without linking any libraries (header-only). Disable the functionality if that is not the case. Fixes bitcoin/bitcoin#24314. ACKs for top commit: fanquake: ACK abc057c6030b2a0ddab46835a7801054da677781 Tree-SHA512: ed2a32b1f751ec6f88cc7220766edd4cdab93c1d0515c892aa3094ee8d5b13ef569830d6e7a7a00c0197b117585dc526d00d943cc99a1f8c8a66ac4e20fe2061
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 452b7deec7..5f3aacf888 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1437,8 +1437,20 @@ if test "$use_external_signer" != "no"; then
use_external_signer="no";
;;
*)
- use_external_signer="yes"
- AC_DEFINE([ENABLE_EXTERNAL_SIGNER], [1], [Define if external signer support is enabled])
+ AC_MSG_CHECKING([whether Boost.Process can be used])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <boost/process.hpp>]])],
+ [have_boost_process="yes"],
+ [have_boost_process="no"])
+ AC_MSG_RESULT([$have_boost_process])
+ if test "$have_boost_process" == "yes"; then
+ use_external_signer="yes"
+ AC_DEFINE([ENABLE_EXTERNAL_SIGNER], [1], [Define if external signer support is enabled])
+ else
+ if test "$use_external_signer" = "yes"; then
+ AC_MSG_ERROR([External signing is not supported for this Boost version])
+ fi
+ use_external_signer="no";
+ fi
;;
esac
fi