aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-06-23 14:43:00 +0800
committerfanquake <fanquake@gmail.com>2021-06-23 15:48:42 +0800
commit957f3584277d33b44b9f1618142f743e4083eb5d (patch)
treef4d63043bcdb06d0a2ba43bcae01421194623410 /configure.ac
parentdf2c93321765c7f77935fd92d31722d7b65a53db (diff)
downloadbitcoin-957f3584277d33b44b9f1618142f743e4083eb5d.tar.xz
build: remove check for Boost Process header
Now that we require Boost 1.64.0+, Boost Process will be available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 3 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index e63abd5de4..88f91004af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1422,18 +1422,6 @@ if test x$use_boost = xyes; then
AX_BOOST_SYSTEM
AX_BOOST_FILESYSTEM
- dnl Opt-in to Boost Process if external signer support is requested
- if test "x$use_external_signer" != xno; then
- AC_MSG_CHECKING(for Boost Process)
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <boost/process.hpp>]],
- [[ boost::process::child* child = new boost::process::child; delete child; ]])],
- [ AC_MSG_RESULT(yes)
- AC_DEFINE([ENABLE_EXTERNAL_SIGNER],,[define if external signer support is enabled])
- ],
- [ AC_MSG_ERROR([Boost::Process is required for external signer support, but not available!])]
- )
- fi
-
if test x$suppress_external_warnings != xno; then
BOOST_CPPFLAGS=SUPPRESS_WARNINGS($BOOST_CPPFLAGS)
fi
@@ -1441,6 +1429,9 @@ if test x$use_boost = xyes; then
BOOST_LIBS="$BOOST_LDFLAGS $BOOST_SYSTEM_LIB $BOOST_FILESYSTEM_LIB"
fi
+if test "x$use_external_signer" != xno; then
+ AC_DEFINE([ENABLE_EXTERNAL_SIGNER],,[define if external signer support is enabled])
+fi
AM_CONDITIONAL([ENABLE_EXTERNAL_SIGNER], [test "x$use_external_signer" = "xyes"])
dnl Check for reduced exports