aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-03-09 21:04:50 +0200
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-06-13 20:07:10 +0300
commit44a14afbb889633a6c9a322a5aeca2e1b2cbdbd8 (patch)
treef1d6df1d690a68a0a167bf0e017bbc43ea0a182c /configure.ac
parent10cbae0c399302b0f8b1aa847c4246ba60bf25ee (diff)
downloadbitcoin-44a14afbb889633a6c9a322a5aeca2e1b2cbdbd8.tar.xz
build: Drop dead non-pkg-config code for qrencode check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 5864ee70b7..cf583e2cca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1302,9 +1302,6 @@ if test x$use_pkgconfig = xyes; then
m4_ifdef(
[PKG_CHECK_MODULES],
[
- if test x$use_qr != xno; then
- BITCOIN_QT_CHECK([PKG_CHECK_MODULES([QR], [libqrencode], [have_qrencode=yes], [have_qrencode=no])])
- fi
if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench != xnonononono; then
PKG_CHECK_MODULES([EVENT], [libevent >= 2.0.21], [use_libevent=yes], [AC_MSG_ERROR(libevent version 2.0.21 or greater not found.)])
if test x$TARGET_OS != xwindows; then
@@ -1322,11 +1319,12 @@ else
AC_CHECK_LIB([event_pthreads],[main],EVENT_PTHREADS_LIBS=-levent_pthreads,AC_MSG_ERROR(libevent_pthreads missing))
fi
fi
+fi
- if test x$use_qr != xno; then
- BITCOIN_QT_CHECK([AC_CHECK_LIB([qrencode], [main],[QR_LIBS=-lqrencode], [have_qrencode=no])])
- BITCOIN_QT_CHECK([AC_CHECK_HEADER([qrencode.h],, have_qrencode=no)])
- fi
+dnl QR Code encoding library check
+
+if test "x$use_qr" != xno; then
+ BITCOIN_QT_CHECK([PKG_CHECK_MODULES([QR], [libqrencode], [have_qrencode=yes], [have_qrencode=no])])
fi
dnl ZMQ check