aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPerlover <perlover@perlover.com>2021-11-26 17:27:48 +0100
committerPerlover <perlover@perlover.com>2021-12-01 13:05:58 +0100
commit091ccc38c2e589b649648cbcc99aca4802f98775 (patch)
treed1bd0d4609174c5e3d1a3de94b33dce150514222 /configure.ac
parente7507f333bc93047d0baadea4fde19f770dacb56 (diff)
downloadbitcoin-091ccc38c2e589b649648cbcc99aca4802f98775.tar.xz
The evhttp_connection_get_peer function from libevent changes the type of the second parameter. Fixing the problem.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 77f45e2133..4f05046b6a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1510,6 +1510,16 @@ if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench
fi
fi
+AC_MSG_CHECKING([if evhttp_connection_get_peer expects const char**])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <cstdint>
+ #include <event2/http.h>
+ ]],
+ [[ evhttp_connection_get_peer((evhttp_connection*) nullptr,(const char**) nullptr,(uint16_t*) nullptr); ]])],
+ [ AC_MSG_RESULT([yes]); AC_DEFINE([HAVE_EVHTTP_CONNECTION_GET_PEER_CONST_CHAR], [1], [Define this symbol if evhttp_connection_get_peer expects const char**]) ],
+ [ AC_MSG_RESULT([no]); AC_DEFINE([HAVE_EVHTTP_CONNECTION_GET_PEER_CONST_CHAR], [0], [Define this symbol if evhttp_connection_get_peer expects const char**]) ]
+)
+
dnl QR Code encoding library check
if test "x$use_qr" != xno; then
@@ -1870,6 +1880,7 @@ AC_SUBST(HAVE_BUILTIN_PREFETCH)
AC_SUBST(HAVE_MM_PREFETCH)
AC_SUBST(HAVE_STRONG_GETAUXVAL)
AC_SUBST(ANDROID_ARCH)
+AC_SUBST(HAVE_EVHTTP_CONNECTION_GET_PEER_CONST_CHAR)
AC_CONFIG_FILES([Makefile src/Makefile doc/man/Makefile share/setup.nsi share/qt/Info.plist test/config.ini])
AC_CONFIG_FILES([contrib/devtools/split-debug.sh],[chmod +x contrib/devtools/split-debug.sh])
AM_COND_IF([HAVE_DOXYGEN], [AC_CONFIG_FILES([doc/Doxyfile])])