aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-12-22 11:55:04 +0800
committerfanquake <fanquake@gmail.com>2022-02-03 18:35:52 +0800
commit07269321f38e46e9e02f16d7cd135ea90692638d (patch)
tree3309668b659ef00da739bfb2e1f5eb2f78796f9c /configure.ac
parentb87f9c5edf3895df9650131fcf8551c3ad1d7301 (diff)
downloadbitcoin-07269321f38e46e9e02f16d7cd135ea90692638d.tar.xz
build: remove Boost::system usage
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index adefbbc2f9..078e113e95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1407,13 +1407,12 @@ if test "$use_boost" = "yes"; then
if test "$want_boost" = "no"; then
AC_MSG_ERROR([only libbitcoinconsensus can be built without Boost])
fi
- AX_BOOST_SYSTEM
if test "$suppress_external_warnings" != "no"; then
BOOST_CPPFLAGS=SUPPRESS_WARNINGS($BOOST_CPPFLAGS)
fi
- BOOST_LIBS="$BOOST_LDFLAGS $BOOST_SYSTEM_LIB"
+ BOOST_LIBS="$BOOST_LDFLAGS"
fi
if test "$use_external_signer" != "no"; then