aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-06-28 16:00:06 +0800
committerfanquake <fanquake@gmail.com>2022-02-03 18:35:41 +0800
commitffc89d1f21258553c0087b774a9ea1ce84139d4f (patch)
tree583c400f93118c6aee958a78e426dcba46232a0d /configure.ac
parentc194293883fbb656779102309b2cb3e60889feff (diff)
downloadbitcoin-ffc89d1f21258553c0087b774a9ea1ce84139d4f.tar.xz
build: add support for std::filesystem
Add a macro to check if linking with -lstdc++fs or -lc++fs is required.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bef3973996..5db104f0d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -83,6 +83,9 @@ AX_CXX_COMPILE_STDCXX([17], [noext], [mandatory])
dnl Check if -latomic is required for <std::atomic>
CHECK_ATOMIC
+dnl check if additional link flags are required for std::filesystem
+CHECK_FILESYSTEM
+
dnl Unless the user specified OBJCXX, force it to be the same as CXX. This ensures
dnl that we get the same -std flags for both.
m4_ifdef([AC_PROG_OBJCXX],[