aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPerlover <perlover@perlover.com>2021-12-07 17:02:04 +0100
committerPerlover <perlover@perlover.com>2021-12-07 17:02:04 +0100
commitc62d763fc313585d79ad833c9d729f6acf2652aa (patch)
tree932fe130085e4da845c9f5c433c53d372546d385 /configure.ac
parent091ccc38c2e589b649648cbcc99aca4802f98775 (diff)
downloadbitcoin-c62d763fc313585d79ad833c9d729f6acf2652aa.tar.xz
Necessary improvements to make configure work without libevent installed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 19 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 4f05046b6a..441e7791e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1510,15 +1510,25 @@ if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench
fi
fi
-AC_MSG_CHECKING([if evhttp_connection_get_peer expects const char**])
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include <cstdint>
- #include <event2/http.h>
- ]],
- [[ evhttp_connection_get_peer((evhttp_connection*) nullptr,(const char**) nullptr,(uint16_t*) nullptr); ]])],
- [ AC_MSG_RESULT([yes]); AC_DEFINE([HAVE_EVHTTP_CONNECTION_GET_PEER_CONST_CHAR], [1], [Define this symbol if evhttp_connection_get_peer expects const char**]) ],
- [ AC_MSG_RESULT([no]); AC_DEFINE([HAVE_EVHTTP_CONNECTION_GET_PEER_CONST_CHAR], [0], [Define this symbol if evhttp_connection_get_peer expects const char**]) ]
-)
+if test x$use_libevent = xyes; then
+ TEMP_CXXFLAGS="$CXXFLAGS"
+ CXXFLAGS="$CXXFLAGS $EVENT_CFLAGS"
+ AC_MSG_CHECKING([if evhttp_connection_get_peer expects const char**])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <cstdint>
+ #include <event2/http.h>
+ ]], [[
+ evhttp_connection *conn = (evhttp_connection *)1;
+ const char *host;
+ uint16_t port;
+
+ evhttp_connection_get_peer(conn, &host, &port);
+ ]])],
+ [ AC_MSG_RESULT([yes]); AC_DEFINE([HAVE_EVHTTP_CONNECTION_GET_PEER_CONST_CHAR], [1], [Define this symbol if evhttp_connection_get_peer expects const char**]) ],
+ [ AC_MSG_RESULT([no]) ]
+ )
+ CXXFLAGS="$TEMP_CXXFLAGS"
+fi
dnl QR Code encoding library check