aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Atack <jon@atack.com>2019-08-15 13:16:24 +0200
committerJon Atack <jon@atack.com>2019-08-16 11:51:07 +0200
commita6c1fc3cd96e68d00b747ee91ea00dd66cca60e0 (patch)
treeade4cd8e22c608700c3c7a942559a16f465158cd /configure.ac
parent8fc7f0cba9b1b60ce25d6a8ba51052af1461f825 (diff)
downloadbitcoin-a6c1fc3cd96e68d00b747ee91ea00dd66cca60e0.tar.xz
build: echo prop tests status during build
Enable users to see if the prop tests are enabled during the build. This can be particularly helpful as property-based tests are silently auto-enabled by default if librapidcheck is found. Minor fixes to the docs and help grammar for this option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4fd285bc8d..35bb0c0231 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,7 +133,7 @@ AC_ARG_ENABLE(gui-tests,
AC_ARG_WITH([rapidcheck],
[AS_HELP_STRING([--with-rapidcheck],
- [enable RapidCheck property based tests (default is yes if librapidcheck is found)])],
+ [enable RapidCheck property-based tests (default is yes if librapidcheck is found)])],
[use_rapidcheck=$withval],
[use_rapidcheck=auto])
@@ -1275,7 +1275,7 @@ AC_CHECK_DECLS([EVP_MD_CTX_new],,,[AC_INCLUDES_DEFAULT
])
CXXFLAGS="${save_CXXFLAGS}"
-dnl RapidCheck Property Based Testing
+dnl RapidCheck property-based testing
enable_property_tests=no
if test "x$use_rapidcheck" = xauto; then
@@ -1657,6 +1657,7 @@ fi
echo " with zmq = $use_zmq"
echo " with test = $use_tests"
if test x$use_tests != xno; then
+ echo " with prop = $enable_property_tests"
echo " with fuzz = $enable_fuzz"
fi
echo " with bench = $use_bench"