aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-11-27 16:20:47 +0800
committerfanquake <fanquake@gmail.com>2022-02-22 15:37:13 +0000
commit80e78b6a0479094cae642726f74a17d09b708ddc (patch)
tree2633d755f1ed6ab8c5941a73d9a5bcdc8b3e51da /configure.ac
parentc44e734dca64a15fae92255a5d848c04adaad2fa (diff)
downloadbitcoin-80e78b6a0479094cae642726f74a17d09b708ddc.tar.xz
build: pass win32-dll to LT_INIT()
This is the recommended way to support building PE DLLs with modern mingw toolchains and libtool. I made a similar change upstream in the secp256k1 repo: https://github.com/bitcoin-core/secp256k1/pull/1022. Note that we already pass `-no-undefined` to our libtool LDFLAGS. > This option should be used if the package has been ported to build clean > dlls on win32 platforms. > If this macro is not used, libtool will assume that the package libraries > are not dll clean and will build only static libraries on win32 hosts. See: https://www.gnu.org/software/libtool/manual/libtool.html#LT_005fINIT https://www.gnu.org/software/gnulib/manual/html_node/Libtool-and-Windows.html https://autotools.io/libtool/windows.html https://github.com/bitcoin-core/secp256k1/issues/923
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 222fa94946..ae21dd9a7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,7 +100,7 @@ dnl sets RPATH for any directories in the dynamic linker search path.
dnl See more: https://wiki.debian.org/RpathIssue
LT_PREREQ([1.5.2])
dnl Libtool init checks.
-LT_INIT([pic-only])
+LT_INIT([pic-only win32-dll])
dnl Check/return PATH for base programs.
AC_PATH_TOOL([AR], [ar])