aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-01-04 15:33:20 +0800
committerfanquake <fanquake@gmail.com>2022-01-04 15:33:25 +0800
commit4eedabaf6f1496ba9ecb5e923d0d80348a0f9678 (patch)
tree0ad3526b8205067f75a1c0f2d7265afd868fa1b5 /configure.ac
parent2f37b221d183dfc8136fa71730acb8f218ad0dcb (diff)
parent1bf3809dd1d73f24ec5cf658733da76fc2ca36a7 (diff)
downloadbitcoin-4eedabaf6f1496ba9ecb5e923d0d80348a0f9678.tar.xz
Merge bitcoin/bitcoin#23947: build: use host_os instead of TARGET_OS in configure output
1bf3809dd1d73f24ec5cf658733da76fc2ca36a7 build: use host_os instead of TARGET_OS in configure output (fanquake) Pull request description: `TARGET_OS` was convenient, as a readable host name for most of our targeted platforms, however unless we add more code to configure to detect more hosts, it's easier just use `host_os` (it's also more informative). i.e FreeBSD master ```bash target os = build os = freebsd13.0 ``` this PR: ```bash target os = freebsd13.0 build os = freebsd13.0 ``` ACKs for top commit: hebasto: ACK 1bf3809dd1d73f24ec5cf658733da76fc2ca36a7 Tree-SHA512: 606d92f60ce3f2f6ab1f54e29b5c179048c62ba51336b272c081b1e009128dd83705b181cfe30991c7a51d9c63e8ba2076bfed9e6112e7d1a74a7f947c5754f5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9ad5a3f033..9e48099fd3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1939,7 +1939,7 @@ echo " gprof enabled = $enable_gprof"
echo " werror = $enable_werror"
echo " LTO = $enable_lto"
echo
-echo " target os = $TARGET_OS"
+echo " target os = $host_os"
echo " build os = $build_os"
echo
echo " CC = $CC"