aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonas Schnelli <dev@jonasschnelli.ch>2020-11-24 15:08:28 +0100
committerJonas Schnelli <dev@jonasschnelli.ch>2020-11-24 15:08:28 +0100
commit982e548a9a78b1b0abad59b54c780b6b06570452 (patch)
treee6bb06c182ca84984a14fd1cd77dc2dc6c860cb6 /configure.ac
parent31c9987976af8ac5ad40091256ac41a2ccb078cd (diff)
downloadbitcoin-982e548a9a78b1b0abad59b54c780b6b06570452.tar.xz
Don't set BDB flags when configuring without
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a512fce83e..e89d86df8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -643,7 +643,7 @@ case $host in
bdb_prefix=$($BREW --prefix berkeley-db4 2>/dev/null)
qt5_prefix=$($BREW --prefix qt5 2>/dev/null)
- if test x$bdb_prefix != x && test "x$BDB_CFLAGS" = "x" && test "x$BDB_LIBS" = "x"; then
+ if test x$bdb_prefix != x && test "x$BDB_CFLAGS" = "x" && test "x$BDB_LIBS" = "x" && test "$use_bdb" != "no"; then
dnl This must precede the call to BITCOIN_FIND_BDB48 below.
BDB_CFLAGS="-I$bdb_prefix/include"
BDB_LIBS="-L$bdb_prefix/lib -ldb_cxx-4.8"