aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-02-20 17:39:33 +0200
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-02-22 13:00:42 +0200
commit69978858a4d8a9c34070f96133b8f95737a6505b (patch)
treeeb50b1bfc5973e327ca1f7fa57e3aa33a61db9c3 /configure.ac
parent2199ef79cba865af7949c3a55938ad54519ca5b8 (diff)
downloadbitcoin-69978858a4d8a9c34070f96133b8f95737a6505b.tar.xz
build: Fix Boost.Process check for Boost 1.73 and older
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c6fde99435..cc0401eb6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1438,9 +1438,13 @@ if test "$use_external_signer" != "no"; then
;;
*)
AC_MSG_CHECKING([whether Boost.Process can be used])
+ TEMP_LDFLAGS="$LDFLAGS"
+ dnl Boost 1.73 and older require the following workaround.
+ LDFLAGS="$LDFLAGS $PTHREAD_CFLAGS"
AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <boost/process.hpp>]])],
[have_boost_process="yes"],
[have_boost_process="no"])
+ LDFLAGS="$TEMP_LDFLAGS"
AC_MSG_RESULT([$have_boost_process])
if test "$have_boost_process" = "yes"; then
use_external_signer="yes"