aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
author0xb10c <0xb10c@gmail.com>2021-12-07 19:19:59 +0100
committer0xb10c <0xb10c@gmail.com>2022-01-06 11:03:55 +0100
commit6200fbf54fa919899d99f1cdd5ef88ec8b074cd6 (patch)
tree8eb879095585345c491e0ed18872ce08154ce10a /configure.ac
parente158a2a7aa501da635cb34414abd0c092216e5f4 (diff)
downloadbitcoin-6200fbf54fa919899d99f1cdd5ef88ec8b074cd6.tar.xz
build: rename --enable-ebpf to --enable-usdt
eBPF is a Linux kernel technology used to "extend the capabilities of the kernel without requiring to change kernel source code or load kernel modules". While Userspace, Statically Defined Tracing (USDT) uses eBPF under the hood, --enable-usdt better resembles that support for USDT is enabled, and tracepoints will be included in the binary.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 10 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 9e48099fd3..fefd0d2972 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,11 +137,11 @@ AC_ARG_WITH([bdb],
[use_bdb=$withval],
[use_bdb=auto])
-AC_ARG_ENABLE([ebpf],
- [AS_HELP_STRING([--enable-ebpf],
- [enable eBPF tracing (default is yes if sys/sdt.h is found)])],
- [use_ebpf=$enableval],
- [use_ebpf=yes])
+AC_ARG_ENABLE([usdt],
+ [AS_HELP_STRING([--enable-usdt],
+ [enable tracepoints for Userspace, Statically Defined Tracing (default is yes if sys/sdt.h is found)])],
+ [use_usdt=$enableval],
+ [use_usdt=yes])
AC_ARG_WITH([miniupnpc],
[AS_HELP_STRING([--with-miniupnpc],
@@ -1341,15 +1341,15 @@ if test "$enable_wallet" != "no"; then
fi
fi
-if test "$use_ebpf" != "no"; then
- AC_MSG_CHECKING([whether eBPF tracepoints are supported])
+if test "$use_usdt" != "no"; then
+ AC_MSG_CHECKING([whether Userspace, Statically Defined Tracing tracepoints are supported])
AC_COMPILE_IFELSE([
AC_LANG_PROGRAM(
[#include <sys/sdt.h>],
[DTRACE_PROBE("context", "event");]
)],
- [AC_MSG_RESULT([yes]); have_sdt=yes; AC_DEFINE([ENABLE_TRACING], [1], [Define to 1 to enable eBPF user static defined tracepoints])],
- [AC_MSG_RESULT([no]); have_sdt=no;]
+ [AC_MSG_RESULT([yes]); AC_DEFINE([ENABLE_TRACING], [1], [Define to 1 to enable tracepoints for Userspace, Statically Defined Tracing])],
+ [AC_MSG_RESULT([no]); use_usdt=no;]
)
fi
@@ -1763,7 +1763,6 @@ AM_CONDITIONAL([TARGET_WINDOWS], [test "$TARGET_OS" = "windows"])
AM_CONDITIONAL([ENABLE_WALLET], [test "$enable_wallet" = "yes"])
AM_CONDITIONAL([USE_SQLITE], [test "$use_sqlite" = "yes"])
AM_CONDITIONAL([USE_BDB], [test "$use_bdb" = "yes"])
-AM_CONDITIONAL([ENABLE_TRACING], [test "$have_sdt" = "yes"])
AM_CONDITIONAL([ENABLE_TESTS], [test "$BUILD_TEST" = "yes"])
AM_CONDITIONAL([ENABLE_FUZZ], [test "$enable_fuzz" = "yes"])
AM_CONDITIONAL([ENABLE_FUZZ_BINARY], [test "$enable_fuzz_binary" = "yes"])
@@ -1932,7 +1931,7 @@ echo " with bench = $use_bench"
echo " with upnp = $use_upnp"
echo " with natpmp = $use_natpmp"
echo " use asm = $use_asm"
-echo " ebpf tracing = $have_sdt"
+echo " USDT tracing = $use_usdt"
echo " sanitizers = $use_sanitizers"
echo " debug enabled = $enable_debug"
echo " gprof enabled = $enable_gprof"