aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2013-09-08 02:44:12 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2014-01-18 19:54:50 +0000
commitf930341d8165a16ba3e7d3dc53a36a37dfddeb36 (patch)
treea9cf04e5dad815f6870df92bff05d7861ccf5c85 /configure.ac
parent4a290b526cb064fd698ddb339f6da820d5a60d86 (diff)
downloadbitcoin-f930341d8165a16ba3e7d3dc53a36a37dfddeb36.tar.xz
configure: Internal changes to make building bitcoind and bitcoin-cli optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 15b67173ee..cb9673fe55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -446,6 +446,8 @@ if test x$boost_sleep != xyes; then
AC_MSG_ERROR(No working boost sleep implementation found. If on ubuntu 13.10 with libboost1.54-all-dev remove libboost.1.54-all-dev and use libboost1.53-all-dev)
fi
+build_bitcoind=yes
+build_bitcoin_cli=yes
BITCOIN_QT_INIT
if test x$use_pkgconfig = xyes; then
@@ -482,6 +484,14 @@ fi
BITCOIN_QT_PATH_PROGS([PROTOC], [protoc],$protoc_bin_path)
+AC_MSG_CHECKING([if bitcoind should be enabled])
+AM_CONDITIONAL([BUILD_BITCOIND], [test x$build_bitcoind = xyes])
+AC_MSG_RESULT($build_bitcoind)
+
+AC_MSG_CHECKING([if bitcoin-cli should be enabled])
+AM_CONDITIONAL([BUILD_BITCOIN_CLI], [test x$build_bitcoin_cli = xyes])
+AC_MSG_RESULT($build_bitcoin_cli)
+
dnl sets $bitcoin_enable_qt, $bitcoin_enable_qt_test, $bitcoin_enable_qt_dbus
BITCOIN_QT_CONFIGURE([$use_pkgconfig], [qt4])