aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2013-11-13 10:58:31 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2013-11-13 17:02:27 +0100
commitd6f690f7da2712b79550d909c5cd53432302517c (patch)
treee29a0fb7fbeed0c0194ea64a6759e8bd504937a9 /configure.ac
parentb3e579713f14309a330a44171abd47c2e851a7b0 (diff)
downloadbitcoin-d6f690f7da2712b79550d909c5cd53432302517c.tar.xz
Use C99 printf statements in mingw
Otherwise, format specifiers such as %llu will not work on XP or earlier. This bug was introduced with 51ed9ec9. http://sourceforge.net/apps/trac/mingw-w64/wiki/gnu%20printf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4e105629e8..1b3d91890c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -221,7 +221,7 @@ case $host in
AC_MSG_ERROR("windres not found")
fi
- CPPFLAGS="$CPPFLAGS -D_MT -DWIN32 -D_WINDOWS -DBOOST_THREAD_USE_LIB"
+ CPPFLAGS="$CPPFLAGS -D_MT -DWIN32 -D_WINDOWS -DBOOST_THREAD_USE_LIB -D__USE_MINGW_ANSI_STDIO"
LEVELDB_TARGET_FLAGS="TARGET_OS=OS_WINDOWS_CROSSCOMPILE"
CXXFLAGS="$CXXFLAGS -w"
;;