aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-05-01 12:07:03 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2014-05-01 12:15:36 +0200
commite27c4110d9c47d30fed4b940813c9c8b82a97fbd (patch)
tree288e02bd1addb587a17cfc2c350e74d5545bb56f /configure.ac
parent426dc16f7b74d5dc91a947bb22acb7a3a414bb8f (diff)
downloadbitcoin-e27c4110d9c47d30fed4b940813c9c8b82a97fbd.tar.xz
Remove build-time no-IPv6 setting
The year is 2014. All supported operating systems have IPv6 support, most certainly at build time (this doesn't mean that IPv6 is configured, of course). If noone is exercising the functionality to disable it, that means it doesn't get tested, and IMO it's better to get rid of it. (it's also not used consistently in RPC/boost and Net code...)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 0 insertions, 45 deletions
diff --git a/configure.ac b/configure.ac
index 3e508571e9..6a8afe6e44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,13 +62,6 @@ AC_ARG_ENABLE([upnp-default],
[use_upnp_default=$enableval],
[use_upnp_default=no])
-dnl enable ipv6 support
-AC_ARG_ENABLE([ipv6],
- [AS_HELP_STRING([--enable-ipv6],
- [enable ipv6 (default is yes)])],
- [use_ipv6=$enableval],
- [use_ipv6=yes])
-
AC_ARG_ENABLE(tests,
AS_HELP_STRING([--enable-tests],[compile tests (default is yes)]),
[use_tests=$enableval],
@@ -560,27 +553,6 @@ AC_MSG_RESULT($build_bitcoin_cli)
dnl sets $bitcoin_enable_qt, $bitcoin_enable_qt_test, $bitcoin_enable_qt_dbus
BITCOIN_QT_CONFIGURE([$use_pkgconfig], [qt4])
-
-if test x$use_ipv6 = xyes; then
- dnl Check for ipv6 build requirements
- AC_MSG_CHECKING(for operating system IPv6 support)
- AC_TRY_LINK([
- #if defined(_WINDOWS)
- #include <winsock2.h>
- #else
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #endif
- ],[
- #if !defined(_WINDOWS)
- struct in6_addr ipv6Addr;
- struct sockaddr_in6 addr;
- #endif
- int temp = socket(AF_INET6, SOCK_STREAM, 0);],
- [AC_MSG_RESULT(yes); have_ipv6=yes; AC_DEFINE(HAVE_IPV6, 1, [Define this symbol if you have operating system IPv6 support])],
- [AC_MSG_RESULT(no)]; have_ipv6=no)
-fi
AC_LANG_POP
if test "x$use_ccache" != "xno"; then
@@ -609,22 +581,6 @@ else
AC_MSG_RESULT(no)
fi
-dnl enable ipv6 support
-AC_MSG_CHECKING([whether to build with support for IPv6])
-if test x$have_ipv6 = xno; then
- if test x$use_ipv6 = xyes; then
- AC_MSG_ERROR([IPv6 requested, but cannot be built. use --disable-ipv6])
- fi
- AC_MSG_RESULT(no)
-else
- if test x$use_ipv6 = xyes; then
- AC_MSG_RESULT(yes)
- AC_DEFINE([USE_IPV6],[1],[Define if IPv6 support should be compiled in])
- else
- AC_MSG_RESULT(no)
- fi
-fi
-
dnl enable upnp support
AC_MSG_CHECKING([whether to build with support for UPnP])
if test x$have_miniupnpc = xno; then
@@ -730,7 +686,6 @@ AC_SUBST(COPYRIGHT_YEAR, _COPYRIGHT_YEAR)
AC_SUBST(USE_UPNP)
AC_SUBST(USE_QRCODE)
-AC_SUBST(USE_IPV6)
AC_SUBST(INCLUDES)
AC_SUBST(BOOST_LIBS)
AC_SUBST(TESTDEFS)