aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2014-01-18 20:11:05 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2014-01-18 20:11:05 +0000
commita9dbcf036bc866c2e413b1d068541e35eafdfcd0 (patch)
treed2b2a9adf57993017cca49b5ca08d1a8390ba13d /configure.ac
parentf47299038d3327dcf11467bf56d3985e67c75aa7 (diff)
downloadbitcoin-a9dbcf036bc866c2e413b1d068541e35eafdfcd0.tar.xz
configure: Change --with[out]-qt to --with[out]-gui and add --with[out]-cli and --with[out]-daemon to support more build configurations
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8a4e9828b3..f45a61663a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -446,8 +446,18 @@ if test x$boost_sleep != xyes; then
AC_MSG_ERROR(No working boost sleep implementation found. If on ubuntu 13.10 with libboost1.54-all-dev remove libboost.1.54-all-dev and use libboost1.53-all-dev)
fi
-build_bitcoind=yes
-build_bitcoin_cli=yes
+AC_ARG_WITH([cli],
+ [AS_HELP_STRING([--with-cli],
+ [with CLI (default is yes)])],
+ [build_bitcoin_cli=$withval],
+ [build_bitcoin_cli=yes])
+
+AC_ARG_WITH([daemon],
+ [AS_HELP_STRING([--with-daemon],
+ [with daemon (default is yes)])],
+ [build_bitcoind=$withval],
+ [build_bitcoind=yes])
+
BITCOIN_QT_INIT
if test x$use_pkgconfig = xyes; then
@@ -622,7 +632,7 @@ if test x$bitcoin_enable_qt != xno; then
if test x$use_tests = xyes; then
BUILD_TEST_QT="test"
if test x$bitcoin_enable_qt_test != xyes; then
- AC_MSG_ERROR("Qt Test lib not found. Use --disable-tests or --without-qt.")
+ AC_MSG_ERROR("Qt Test lib not found. Use --disable-tests or --without-gui.")
fi
fi
fi
@@ -631,6 +641,10 @@ if test x$use_tests = xyes; then
BUILD_TEST="test"
fi
+if test "x$use_tests$build_bitcoind$use_qt" = "xnonono"; then
+ AC_MSG_ERROR([No targets! Please specify at least one of: --enable-cli --enable-daemon --enable-gui or --enable-tests])
+fi
+
AM_CONDITIONAL([TARGET_DARWIN], [test x$TARGET_OS = xdarwin])
AM_CONDITIONAL([TARGET_WINDOWS], [test x$TARGET_OS = xwindows])
AM_CONDITIONAL([ENABLE_WALLET],[test x$enable_wallet == xyes])