aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2013-09-18 17:39:18 -0400
committerCory Fields <cory-nospam-@coryfields.com>2013-09-18 17:58:53 -0400
commit5ceb9c963700d4639fb3210b98aa028113e2a9c4 (patch)
treee83bd90f7db113b31f49efff117269a5a277f8e2 /configure.ac
parentdee632cc257bbf581e75e28e3eeccaa901761480 (diff)
downloadbitcoin-5ceb9c963700d4639fb3210b98aa028113e2a9c4.tar.xz
win32: only check for windres for win32, and fail if missing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 11357669dd..0e69903025 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,7 +125,6 @@ AC_PROG_MKDIR_P
AC_PROG_SED
AC_PATH_TOOL(AR, ar)
AC_PATH_TOOL(RANLIB, ranlib)
-AC_PATH_TOOL(WINDRES, windres)
AC_PATH_TOOL(STRIP, strip)
AC_PATH_TOOL(GCOV, gcov)
AC_PATH_PROG(LCOV, lcov)
@@ -183,6 +182,11 @@ case $host in
AC_MSG_WARN("makensis not found. Cannot create installer.")
fi
+ AC_PATH_TOOL(WINDRES, windres, none)
+ if test x$WINDRES = xnone; then
+ AC_MSG_ERROR("windres not found")
+ fi
+
CPPFLAGS="$CPPFLAGS -D_MT -DWIN32 -D_WINDOWS -DBOOST_THREAD_USE_LIB"
LEVELDB_TARGET_FLAGS="TARGET_OS=OS_WINDOWS_CROSSCOMPILE"
CXXFLAGS="$CXXFLAGS -w"