aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-01-05 18:33:23 +0000
committerfanquake <fanquake@gmail.com>2023-01-05 18:33:23 +0000
commit94d0c418c51223f67e50cfa7fa4f4d838f733914 (patch)
tree7a30007d97e7eb28b1ea198f91211f0c35fdc318 /configure.ac
parentb4fb0a3255d39d7acf334d09b675885462e31c60 (diff)
build: remove already tested headers from AC_CHECK_HEADERS
These headers are already included in a default set which are checked early during configure. We already use at least sys/types.h and unistd.h unconditionally in configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4b55bef5c7..603c2bcf33 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1006,7 +1006,7 @@ if test "$TARGET_OS" = "darwin"; then
AX_CHECK_LINK_FLAG([-Wl,-bind_at_load], [HARDENED_LDFLAGS="$HARDENED_LDFLAGS -Wl,-bind_at_load"], [], [$LDFLAG_WERROR])
fi
-AC_CHECK_HEADERS([endian.h sys/endian.h byteswap.h unistd.h sys/types.h sys/stat.h sys/select.h sys/prctl.h sys/sysctl.h vm/vm_param.h sys/vmmeter.h sys/resources.h])
+AC_CHECK_HEADERS([endian.h sys/endian.h byteswap.h sys/select.h sys/prctl.h sys/sysctl.h vm/vm_param.h sys/vmmeter.h sys/resources.h])
AC_CHECK_DECLS([getifaddrs, freeifaddrs],[CHECK_SOCKET],,
[#include <sys/types.h>