aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-07-17 14:09:44 +0100
committerfanquake <fanquake@gmail.com>2023-07-18 14:27:30 +0100
commit08eb5f1b67e2af009549717eb5c66b7d7905731f (patch)
treef33c631d7931557469d1aef69d3760eb288bdb0e /configure.ac
parent673acab223c0f896767b1ae784659df9f95452ae (diff)
ci: document that -Wreturn-type has been fixed upstream (Windows)
`noreturn` attributes have been added to the mingw-w64 headers, meaning that from 11.0.0 onwards, you'll no-longer see `-Wreturn-type` warnings when using assert(false): https://github.com/mingw-w64/mingw-w64/commit/1690994f515910a31b9fb7c7bd3a52d4ba987abe. Add -Wno-return-type to the Windows CI, where is should have been all along, and document why it's required. This can be dropped when we are using the fixed version of the mingw-w64 headers there. Drop the -Werror -Wno-return-type special case from our build system. -Wreturn-type is on by default in Clang and GCC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 9e3a7cca8a..d6f822845a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -427,12 +427,6 @@ if test "$enable_werror" = "yes"; then
AC_MSG_ERROR([enable-werror set but -Werror is not usable])
fi
ERROR_CXXFLAGS=$CXXFLAG_WERROR
-
- dnl -Wreturn-type is broken in GCC for MinGW-w64.
- dnl https://sourceforge.net/p/mingw-w64/bugs/306/
- AX_CHECK_COMPILE_FLAG([-Werror=return-type], [], [ERROR_CXXFLAGS="$ERROR_CXXFLAGS -Wno-error=return-type"], [$CXXFLAG_WERROR],
- [AC_LANG_SOURCE([[#include <cassert>
- int f(){ assert(false); }]])])
fi
if test "$CXXFLAGS_overridden" = "no"; then