aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2019-04-26 12:44:36 -0400
committerMarcoFalke <falke.marco@gmail.com>2019-04-26 12:44:38 -0400
commitb1e013e4fa21923d8b49aa6fccbbaf77721c7d90 (patch)
tree2d1e67a821ed9c65ad3aa50b7e68af6a19a9c976 /configure.ac
parent5046d4e911aa5ef4d546e8a6d66ca1810c89592a (diff)
parent4207c1b35c2e2ee1c9217cc7db3290a24c3b4b52 (diff)
downloadbitcoin-b1e013e4fa21923d8b49aa6fccbbaf77721c7d90.tar.xz
Merge #13788: Fix --disable-asm for newer assembly checks/code
4207c1b35c configure: Initialise assembly enable_* variables (Luke Dashjr) afe0875577 configure: Skip assembly support checks, when assembly is disabled (Luke Dashjr) d8ab8dc12d configure: Invert --enable-asm help string since default is now enabled (Luke Dashjr) Pull request description: Fixes #13759 Also inverts the help (so it shows `--disable-asm` like other enabled-by-default options, and initialises the flag variables. ACKs for commit 4207c1: laanwj: makes sense, utACK 4207c1b35c2e2ee1c9217cc7db3290a24c3b4b52 achow101: utACK 4207c1b35c2e2ee1c9217cc7db3290a24c3b4b52 ken2812221: ACK 4207c1b35c2e2ee1c9217cc7db3290a24c3b4b52 practicalswift: tACK 4207c1b35c2e2ee1c9217cc7db3290a24c3b4b52 Tree-SHA512: a30be1008fd8f019db34073f78e90a3c4ad3767d88d7c20ebb83e99c7abc23552f7da3ac8bd20f727405799aff1ecb6044cf869653f8db70478a074d0b877e0a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a3ba8ce808..66437ff7ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,8 +195,8 @@ AC_ARG_ENABLE([glibc-back-compat],
[use_glibc_compat=no])
AC_ARG_ENABLE([asm],
- [AS_HELP_STRING([--enable-asm],
- [Enable assembly routines (default is yes)])],
+ [AS_HELP_STRING([--disable-asm],
+ [disable assembly routines (enabled by default)])],
[use_asm=$enableval],
[use_asm=yes])
@@ -339,6 +339,13 @@ if test "x$CXXFLAGS_overridden" = "xno"; then
AX_CHECK_COMPILE_FLAG([-Wimplicit-fallthrough],[NOWARN_CXXFLAGS="$NOWARN_CXXFLAGS -Wno-implicit-fallthrough"],,[[$CXXFLAG_WERROR]])
fi
+enable_hwcrc32=no
+enable_sse41=no
+enable_avx2=no
+enable_shani=no
+
+if test "x$use_asm" = "xyes"; then
+
# Check for optional instruction set support. Enabling these does _not_ imply that all code will
# be compiled with them, rather that specific objects/libs may use them after checking for runtime
# compatibility.
@@ -416,6 +423,8 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
)
CXXFLAGS="$TEMP_CXXFLAGS"
+fi
+
CPPFLAGS="$CPPFLAGS -DHAVE_BUILD_INFO -D__STDC_FORMAT_MACROS"
AC_ARG_WITH([utils],