aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-06-23 09:00:54 +0300
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-06-23 09:00:54 +0300
commita661449a2eeaf88efda36b6a84084dcbfe5b24eb (patch)
treece15748e1ca005f62d61d29b529881eaff67d31a /configure.ac
parent90b95e7929463d6127c1b24fe1bf457d750a045c (diff)
downloadbitcoin-a661449a2eeaf88efda36b6a84084dcbfe5b24eb.tar.xz
build: Drop use_pkgconfig check for libmultiprocess check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index f701bb85be..b728bf2283 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1365,12 +1365,10 @@ dnl libmultiprocess library check
libmultiprocess_found=no
if test "x$with_libmultiprocess" = xyes || test "x$with_libmultiprocess" = xauto; then
- if test "x$use_pkgconfig" = xyes; then
- m4_ifdef([PKG_CHECK_MODULES], [PKG_CHECK_MODULES([LIBMULTIPROCESS], [libmultiprocess], [
- libmultiprocess_found=yes;
- libmultiprocess_prefix=`$PKG_CONFIG --variable=prefix libmultiprocess`;
- ], [true])])
- fi
+ m4_ifdef([PKG_CHECK_MODULES], [PKG_CHECK_MODULES([LIBMULTIPROCESS], [libmultiprocess], [
+ libmultiprocess_found=yes;
+ libmultiprocess_prefix=`$PKG_CONFIG --variable=prefix libmultiprocess`;
+ ], [true])])
elif test "x$with_libmultiprocess" != xno; then
AC_MSG_ERROR([--with-libmultiprocess=$with_libmultiprocess value is not yes, auto, or no])
fi