aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-03-09 20:26:30 +0200
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-06-13 20:01:27 +0300
commit6fd2118e777d11cbc81a45313d1a7d6400e34f3f (patch)
tree4b2bf2e8de25ef64d02e2de5678f103f562423fe /configure.ac
parente9edbe4dbd8c24a779de7d92e5f10c870aab5511 (diff)
downloadbitcoin-6fd2118e777d11cbc81a45313d1a7d6400e34f3f.tar.xz
build: Drop dead non-pkg-config code for UNIVALUE check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 1 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index ea87c0767e..edf741c5da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1371,24 +1371,7 @@ if test x$build_bitcoin_wallet$build_bitcoin_cli$build_bitcoin_tx$build_bitcoind
else
if test x$system_univalue != xno ; then
- found_univalue=no
- if test x$use_pkgconfig = xyes; then
- : #NOP
- m4_ifdef(
- [PKG_CHECK_MODULES],
- [
- PKG_CHECK_MODULES([UNIVALUE],[libunivalue >= 1.0.4],[found_univalue=yes],[true])
- ]
- )
- else
- AC_CHECK_HEADER([univalue.h],[
- AC_CHECK_LIB([univalue], [main],[
- UNIVALUE_LIBS=-lunivalue
- found_univalue=yes
- ],[true])
- ],[true])
- fi
-
+ PKG_CHECK_MODULES([UNIVALUE], [libunivalue >= 1.0.4], [found_univalue=yes], [found_univalue=no])
if test x$found_univalue = xyes ; then
system_univalue=yes
need_bundled_univalue=no