aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2020-06-05 11:50:34 +0200
committerVasil Dimov <vd@FreeBSD.org>2020-06-05 11:50:34 +0200
commit00124713912ead4ce610d519bb3ebab7e31cbea7 (patch)
treed13f848cc7877141be17086f393ef179a9b8a2b2 /configure.ac
parent01b45b2e016f0b0907929e818216edf7157fb03a (diff)
downloadbitcoin-00124713912ead4ce610d519bb3ebab7e31cbea7.tar.xz
build: turn on --enable-c++17 by --enable-fuzz
Fuzzing code uses C++17 specific code (e.g. std::optional), so it is not possible to compile with --enable-fuzz and without --enable-c++17. Thus, turn on --enable-c++17 whenever --enable-fuzz is used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index eb58eac172..0e263a473f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,7 +69,7 @@ AC_ARG_ENABLE([c++17],
[use_cxx17=no])
dnl Require C++11 or C++17 compiler (no GNU extensions)
-if test "x$use_cxx17" = xyes; then
+if test "x$use_cxx17" = xyes -o "x$enable_fuzz" = xyes ; then
AX_CXX_COMPILE_STDCXX([17], [noext], [mandatory])
else
AX_CXX_COMPILE_STDCXX([11], [noext], [mandatory])