aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-07-22 12:15:28 +0800
committerfanquake <fanquake@gmail.com>2020-07-22 18:22:56 +0800
commitef3d4ce4c301caa57946f772f554678cd872fca8 (patch)
treefacd8b5bd132ba7105f1f60b349cdc3e8237f38e /configure.ac
parent2031aa92a32d0613dcc912ff438521e32cea9977 (diff)
downloadbitcoin-ef3d4ce4c301caa57946f772f554678cd872fca8.tar.xz
build: call AC_PATH_TOOL for dsymutil in macOS cross-compile
While testing #19530 I noticed that we couldn't call dsymutil after LTO: ```bash ../libtool: line 10643: x86_64-apple-darwin16-dsymutil: command not found ``` This updates configure to call `AC_PATH_TOOL` so that we end up with the full path to dsymutil, similar to `otool` and `install_name_tool`, ie: `/bitcoin/depends/x86_64-apple-darwin16/share/../native/bin/x86_64-apple-darwin16-otool`.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb63b9fc68..c6b8aafef9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -642,6 +642,7 @@ case $host in
BUILD_OS=darwin
;;
*)
+ AC_PATH_TOOL([DSYMUTIL], [dsymutil], dsymutil)
AC_PATH_TOOL([INSTALLNAMETOOL], [install_name_tool], install_name_tool)
AC_PATH_TOOL([OTOOL], [otool], otool)
AC_PATH_PROGS([GENISOIMAGE], [genisoimage mkisofs],genisoimage)