aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-05-10 19:27:15 +0800
committerfanquake <fanquake@gmail.com>2020-05-10 19:27:15 +0800
commit89fea68ffdbd97394d891177e664f896b3e7d1e6 (patch)
treed37e37432bf319e59df2f738527fb88d5760f98f /configure.ac
parent88d8b4e182bfc75e8496f7046af7aab93307b9d0 (diff)
downloadbitcoin-89fea68ffdbd97394d891177e664f896b3e7d1e6.tar.xz
build: don't pass -w when building for Windows
This has been around since the introduction of autotools. However at this point I'm not sure we'd every want to suppress all warnings when performing a build, and given that CXX FLAGS will have been overriden when cross-compiling for Windows (using depends), this would rarely, if-ever be used anyways. From https://gcc.gnu.org/onlinedocs/gcc/Warning-Options.html: -w Inhibit all warning messages.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index cf04faf6d1..4ba006b41f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -576,9 +576,6 @@ case $host in
fi
CPPFLAGS="$CPPFLAGS -D_MT -DWIN32 -D_WINDOWS -DBOOST_THREAD_USE_LIB -D_WIN32_WINNT=0x0601"
- if test "x$CXXFLAGS_overridden" = "xno"; then
- CXXFLAGS="$CXXFLAGS -w"
- fi
dnl libtool insists upon adding -nostdlib and a list of objects/libs to link against.
dnl That breaks our ability to build dll's with static libgcc/libstdc++/libssp. Override