aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@protonmail.com>2020-04-30 11:16:39 +0200
committerWladimir J. van der Laan <laanwj@protonmail.com>2020-04-30 11:16:56 +0200
commit35ef3c15ef8263b79c6e8f002ceab270f08cd5a5 (patch)
tree04c9d58f6e5f7416e339f395f7684cf0bb80309e /configure.ac
parent63d5ed2fc45846ebab760764a3c07b1062212b3b (diff)
parentc31cbe7cfefc18123eb85ffb2ce509748435efde (diff)
downloadbitcoin-35ef3c15ef8263b79c6e8f002ceab270f08cd5a5.tar.xz
Merge #18591: Add C++17 build to Travis
c31cbe7cfefc18123eb85ffb2ce509748435efde Add C++17 test to Travis (Pieter Wuille) 7829685e27aae25efb32e07368175c8f664b2218 Add configure option for c++17 (Pieter Wuille) 0fbde488b24f62b4bbbde216647941dcac65c81a Support conversion between Spans of compatible types (Pieter Wuille) 7cbfebbf3df0d26f518811e0bfb7abf270c83e37 Update ax_cxx_compile_stdcxx.m4 (Pieter Wuille) Pull request description: This adds a `--enable-c++17` option to the configure script, fixes the only C++17 incompatibility (with a commit taken from #18468), and adds a Travis test for it. This is all off by default, and release builds remain C++11. It implements the first step of the plan in https://github.com/bitcoin/bitcoin/issues/16684. ACKs for top commit: elichai: tACK c31cbe7cfefc18123eb85ffb2ce509748435efde practicalswift: Tested ACK c31cbe7cfefc18123eb85ffb2ce509748435efde hebasto: ACK c31cbe7cfefc18123eb85ffb2ce509748435efde, tested on Linux Mint 19.3 both C++11 and C++17 modes. Compiled and passed tests locally. Tree-SHA512: a4b00776dbceef9c12abbb404c6bcd48f7916ce24c8c7a14116355f64e817578b7fcddbedd5ce435322319d1e4de43429b68553f4d96d970c308fe3e3e59b9d1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5f938c4466..b681f3f6de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,8 +61,20 @@ case $host in
lt_cv_deplibs_check_method="pass_all"
;;
esac
-dnl Require C++11 compiler (no GNU extensions)
-AX_CXX_COMPILE_STDCXX([11], [noext], [mandatory], [nodefault])
+
+AC_ARG_ENABLE([c++17],
+ [AS_HELP_STRING([--enable-c++17],
+ [enable compilation in c++17 mode (disabled by default)])],
+ [use_cxx17=$enableval],
+ [use_cxx17=no])
+
+dnl Require C++11 or C++17 compiler (no GNU extensions)
+if test "x$use_cxx17" = xyes; then
+ AX_CXX_COMPILE_STDCXX([17], [noext], [mandatory])
+else
+ AX_CXX_COMPILE_STDCXX([11], [noext], [mandatory])
+fi
+
dnl Check if -latomic is required for <std::atomic>
CHECK_ATOMIC