aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-06-23 09:01:47 +0300
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-06-23 09:01:47 +0300
commit1739eb23d8a6d272e70f95342323b6fe48b8eb6c (patch)
tree6b8590132db78292ae5787723bdafb9b69f5ad5a /configure.ac
parenta661449a2eeaf88efda36b6a84084dcbfe5b24eb (diff)
downloadbitcoin-1739eb23d8a6d272e70f95342323b6fe48b8eb6c.tar.xz
build: Drop unused use_pkgconfig variable
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index b728bf2283..70abbe9276 100644
--- a/configure.ac
+++ b/configure.ac
@@ -573,7 +573,6 @@ AC_ARG_WITH([daemon],
[build_bitcoind=$withval],
[build_bitcoind=yes])
-use_pkgconfig=yes
case $host in
*mingw*)
TARGET_OS=windows
@@ -678,14 +677,10 @@ case $host in
;;
esac
-if test x$use_pkgconfig = xyes; then
- m4_ifndef([PKG_PROG_PKG_CONFIG], [AC_MSG_ERROR(PKG_PROG_PKG_CONFIG macro not found. Please install pkg-config and re-run autogen.sh.)])
- m4_ifdef([PKG_PROG_PKG_CONFIG], [
- PKG_PROG_PKG_CONFIG
- if test x"$PKG_CONFIG" = "x"; then
- AC_MSG_ERROR(pkg-config not found.)
- fi
- ])
+m4_ifndef([PKG_PROG_PKG_CONFIG], [AC_MSG_ERROR([PKG_PROG_PKG_CONFIG macro not found. Please install pkg-config and re-run autogen.sh])])
+PKG_PROG_PKG_CONFIG
+if test "x$PKG_CONFIG" = x; then
+ AC_MSG_ERROR([pkg-config not found])
fi
if test x$use_extended_functional_tests != xno; then