aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2019-12-12 08:09:43 -0500
committerfanquake <fanquake@gmail.com>2019-12-31 21:58:00 +0300
commitf7453dcc0386a4a1162ced1a490c096afa13178a (patch)
treeddc3ff0e7958c5995ea67359ea4a3a13f7a85734 /configure.ac
parent35fff5be60e853455abc24713481544e91adfedb (diff)
downloadbitcoin-f7453dcc0386a4a1162ced1a490c096afa13178a.tar.xz
build: remove linking librt for backwards compatibility
Now that we require glibc 2.17+, #17538, we can remove linking in librt for backwards compatibility purposes. The clock_* functions from librt were merged into glibc as part of the 2.17 release. * The `clock_*' suite of functions (declared in <time.h>) is now available directly in the main C library. Previously it was necessary to link with -lrt to use these functions. This change has the effect that a single-threaded program that uses a function such as `clock_gettime' (and is not linked with -lrt) will no longer implicitly load the pthreads library at runtime and so will not suffer the overheads associated with multi-thread support in other code such as the C++ runtime library. https://sourceware.org/ml/libc-announce/2012/msg00001.html Note that librt is already not linked by the RISC-V and AARCH64 binaries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 875491fb99..f28c2760cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -693,10 +693,6 @@ AX_GCC_FUNC_ATTRIBUTE([dllimport])
if test x$use_glibc_compat != xno; then
- dnl glibc absorbed clock_gettime in 2.17. librt (its previous location) is safe to link
- dnl in anyway for back-compat.
- AC_CHECK_LIB([rt],[clock_gettime],, AC_MSG_ERROR(librt missing))
-
dnl __fdelt_chk's params and return type have changed from long unsigned int to long int.
dnl See which one is present here.
AC_MSG_CHECKING(__fdelt_chk type)