aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-04-16 22:05:41 +0300
committerfanquake <fanquake@gmail.com>2020-04-23 14:29:07 +0800
commit1d1e3585fee91c5c445fb6e836a79c3ee223f7cf (patch)
tree9af2f5ed107d68901761299c0432c1cfe93de1a3 /configure.ac
parent842b13a5f44846e21d8a0a0eafb4be7234866a26 (diff)
downloadbitcoin-1d1e3585fee91c5c445fb6e836a79c3ee223f7cf.tar.xz
build: Set libevent minimum version to 2.0.21
Github-Pull: #18676 Rebased-From: b68e71796792a9da9daa0a4e759d284d15595230
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 16876ae88b..5128964898 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1265,9 +1265,9 @@ if test x$use_pkgconfig = xyes; then
BITCOIN_QT_CHECK([PKG_CHECK_MODULES([QR], [libqrencode], [have_qrencode=yes], [have_qrencode=no])])
fi
if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench != xnonononono; then
- PKG_CHECK_MODULES([EVENT], [libevent],, [AC_MSG_ERROR(libevent not found.)])
+ PKG_CHECK_MODULES([EVENT], [libevent >= 2.0.21],, [AC_MSG_ERROR(libevent version 2.0.21 or greater not found.)])
if test x$TARGET_OS != xwindows; then
- PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads],, [AC_MSG_ERROR(libevent_pthreads not found.)])
+ PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads >= 2.0.21],, [AC_MSG_ERROR(libevent_pthreads version 2.0.21 or greater not found.)])
fi
fi