aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-04-03 14:58:51 +0800
committerfanquake <fanquake@gmail.com>2020-04-03 22:47:59 +0800
commit9e071b00898aedd9632f105a22d976dc6dbc84b1 (patch)
treedcd9fe18d5f554c5e794776da085f52fd91d1b57 /configure.ac
parent08c4994969be20ab268faed2793fb4b9f17722ee (diff)
downloadbitcoin-9e071b00898aedd9632f105a22d976dc6dbc84b1.tar.xz
test: remove rapidcheck integration and tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 0 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 4cfd5c9274..a2d33ff5b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,12 +134,6 @@ AC_ARG_ENABLE(gui-tests,
[use_gui_tests=$enableval],
[use_gui_tests=$use_tests])
-AC_ARG_WITH([rapidcheck],
- [AS_HELP_STRING([--with-rapidcheck],
- [enable RapidCheck property-based tests (default is yes if librapidcheck is found)])],
- [use_rapidcheck=$withval],
- [use_rapidcheck=auto])
-
AC_ARG_ENABLE(bench,
AS_HELP_STRING([--disable-bench],[do not compile benchmarks (default is to compile)]),
[use_bench=$enableval],
@@ -1327,22 +1321,6 @@ else
fi
fi
-dnl RapidCheck property-based testing
-
-enable_property_tests=no
-if test "x$use_rapidcheck" = xauto; then
- AC_CHECK_HEADERS([rapidcheck.h], [enable_property_tests=yes])
-elif test "x$use_rapidcheck" != xno; then
- enable_property_tests=yes
-fi
-
-RAPIDCHECK_LIBS=
-if test "x$enable_property_tests" = xyes; then
- RAPIDCHECK_LIBS=-lrapidcheck
-fi
-AC_SUBST(RAPIDCHECK_LIBS)
-AM_CONDITIONAL([ENABLE_PROPERTY_TESTS], [test x$enable_property_tests = xyes])
-
dnl univalue check
need_bundled_univalue=yes
@@ -1679,7 +1657,6 @@ fi
echo " with zmq = $use_zmq"
echo " with test = $use_tests"
if test x$use_tests != xno; then
- echo " with prop = $enable_property_tests"
echo " with fuzz = $enable_fuzz"
fi
echo " with bench = $use_bench"