aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2019-11-21 13:39:36 +0200
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2019-11-21 13:52:41 +0200
commit651c636f9ed4a60c4cd003e566e3ac6ae6eda3ed (patch)
tree2b95fcd83060bf393808fe4af933fbc9d17f3cb4 /configure.ac
parentb7bc9b8330096d1f4f1fa563b855b88da425226e (diff)
downloadbitcoin-651c636f9ed4a60c4cd003e566e3ac6ae6eda3ed.tar.xz
build: Fix configure report about qr
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2025037bd4..ed9ccade6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1471,18 +1471,16 @@ if test x$bitcoin_enable_qt != xno; then
AC_MSG_CHECKING([whether to build GUI with support for QR codes])
if test x$have_qrencode = xno; then
if test x$use_qr = xyes; then
- AC_MSG_ERROR("QR support requested but cannot be built. use --without-qrencode")
+ AC_MSG_ERROR([QR support requested but cannot be built. Use --without-qrencode])
fi
- AC_MSG_RESULT(no)
+ use_qr=no
else
if test x$use_qr != xno; then
- AC_MSG_RESULT(yes)
AC_DEFINE([USE_QRCODE],[1],[Define if QR support should be compiled in])
use_qr=yes
- else
- AC_MSG_RESULT(no)
fi
fi
+ AC_MSG_RESULT([$use_qr])
if test x$XGETTEXT = x; then
AC_MSG_WARN("xgettext is required to update qt translations")