aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2018-07-27 17:26:43 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2018-07-28 19:34:49 +0000
commit4207c1b35c2e2ee1c9217cc7db3290a24c3b4b52 (patch)
treef936d4bd7d3617dc247436cbaf76de4766382af1 /configure.ac
parentafe087557747f640af90eaca8de8786dc226e56a (diff)
downloadbitcoin-4207c1b35c2e2ee1c9217cc7db3290a24c3b4b52.tar.xz
configure: Initialise assembly enable_* variables
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 11df27220e..13ea660198 100644
--- a/configure.ac
+++ b/configure.ac
@@ -314,6 +314,11 @@ if test "x$CXXFLAGS_overridden" = "xno"; then
AX_CHECK_COMPILE_FLAG([-Wimplicit-fallthrough],[NOWARN_CXXFLAGS="$NOWARN_CXXFLAGS -Wno-implicit-fallthrough"],,[[$CXXFLAG_WERROR]])
fi
+enable_hwcrc32=no
+enable_sse41=no
+enable_avx2=no
+enable_shani=no
+
if test "x$use_asm" = "xyes"; then
# Check for optional instruction set support. Enabling these does _not_ imply that all code will