aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-03-21 14:18:07 +0200
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-03-21 14:18:07 +0200
commitf709ad0c907d87d03002455967cc30ae7d704d80 (patch)
tree8ee974a59daf06e5e1ab3a00dfb1ad3e9b3552b4 /configure.ac
parent5bf45fe2a9642f8ae8f8a12bcbf8f8b4770421ad (diff)
downloadbitcoin-f709ad0c907d87d03002455967cc30ae7d704d80.tar.xz
build: Fix libevent linking for bench_bitcoin binary
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 23a6417a1a..ef87d759f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1255,7 +1255,7 @@ if test x$use_pkgconfig = xyes; then
if test x$use_qr != xno; then
BITCOIN_QT_CHECK([PKG_CHECK_MODULES([QR], [libqrencode], [have_qrencode=yes], [have_qrencode=no])])
fi
- if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests != xnononono; then
+ if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench != xnonononono; then
PKG_CHECK_MODULES([EVENT], [libevent],, [AC_MSG_ERROR(libevent not found.)])
if test x$TARGET_OS != xwindows; then
PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads],, [AC_MSG_ERROR(libevent_pthreads not found.)])
@@ -1275,7 +1275,7 @@ if test x$use_pkgconfig = xyes; then
)
else
- if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests != xnononono; then
+ if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench != xnonononono; then
AC_CHECK_HEADER([event2/event.h],, AC_MSG_ERROR(libevent headers missing),)
AC_CHECK_LIB([event],[main],EVENT_LIBS=-levent,AC_MSG_ERROR(libevent missing))
if test x$TARGET_OS != xwindows; then