aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2019-12-03 17:45:55 -0500
committerfanquake <fanquake@gmail.com>2019-12-03 17:50:30 -0500
commitbd44711e1bb2eee7646f2f8e2e8763d1c216bdb9 (patch)
tree5214d8440832a00c76b7505878885c24d37fd0ea /configure.ac
parente354db787790b84b0b3f34cc55b65446c71e4fa2 (diff)
downloadbitcoin-bd44711e1bb2eee7646f2f8e2e8763d1c216bdb9.tar.xz
build: pass -dead_strip_dylibs to ld on macOS
This strips some unused dylibs from bitcoin-qt. From man ld: Remove dylibs that are unreachable by the entry point or exported symbols. That is, suppresses the generation of load command commands for dylibs which supplied no symbols during the link. This option should not be used when linking against a dylib which is required at runtime for some indirect reason such as the dylib has an important initializer.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2025037bd4..62b70bcb07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -783,6 +783,7 @@ fi
dnl this flag screws up non-darwin gcc even when the check fails. special-case it.
if test x$TARGET_OS = xdarwin; then
AX_CHECK_LINK_FLAG([[-Wl,-dead_strip]], [LDFLAGS="$LDFLAGS -Wl,-dead_strip"])
+ AX_CHECK_LINK_FLAG([[-Wl,-dead_strip_dylibs]], [LDFLAGS="$LDFLAGS -Wl,-dead_strip_dylibs"])
fi
AC_CHECK_HEADERS([endian.h sys/endian.h byteswap.h stdio.h stdlib.h unistd.h strings.h sys/types.h sys/stat.h sys/select.h sys/prctl.h sys/sysctl.h vm/vm_param.h sys/vmmeter.h sys/resources.h])