aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2024-08-05 14:47:00 +0100
committerfanquake <fanquake@gmail.com>2024-08-05 14:54:56 +0100
commitbbcba09cd5ca5fdd9055aaf64781125c5e505576 (patch)
tree11ffa5cae9a17c6f1ffc7f8110d54d9d0e62bb2d /configure.ac
parent37c9abdc4375ce1a1b9186a63e8c133fbb7feebd (diff)
build: remove check for __declspec(dllexport)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index d761911573..ab6fa8b0d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -943,18 +943,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
[ AC_MSG_RESULT([no])]
)
-AC_MSG_CHECKING([for dllexport attribute])
-AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- __declspec(dllexport) int foo(void);
- int main(){}
- ])],
- [
- AC_DEFINE([HAVE_DLLEXPORT_ATTRIBUTE], [1], [Define if the dllexport attribute is supported.])
- AC_MSG_RESULT([yes])
- ],
- [AC_MSG_RESULT([no])]
-)
-
dnl Check for different ways of gathering OS randomness
AC_MSG_CHECKING([for Linux getrandom function])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[