aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2015-10-26 09:09:16 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2015-10-26 09:09:33 +0100
commit5242bb32c7231d3110bfa2fe2f683e9ea18a7444 (patch)
tree2fdfba98e157f600e09e7926ff260778d6ba5e64 /configure.ac
parent867d6c90b85070644c3458e3e7ed168765523361 (diff)
parentd80e3cbece857b293a4903ef49c4d543bb2cfb7f (diff)
downloadbitcoin-5242bb32c7231d3110bfa2fe2f683e9ea18a7444.tar.xz
Merge pull request #6813
d80e3cb Support gathering of code coverage data for RPC tests (dexX7) e3b5e6c Run extended BitcoinJ tests for coverage based on config (dexX7) 45d4ff0 Add config option to enable extended RPC tests for code coverage (dexX7) 8e3a27b Require Python for RPC tests, when using lcov (dexX7) d425877 Remove coverage and test related files, when cleaning up (dexX7) 4d2a926 Ignore coverage data related and temporary test files (dexX7)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4318aafa55..25ace88f32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,7 @@ AC_PATH_TOOL(STRIP, strip)
AC_PATH_TOOL(GCOV, gcov)
AC_PATH_PROG(LCOV, lcov)
AC_PATH_PROG(JAVA, java)
+AC_PATH_PROG(PYTHON, python)
AC_PATH_PROG(GENHTML, genhtml)
AC_PATH_PROG([GIT], [git])
AC_PATH_PROG(CCACHE,ccache)
@@ -106,6 +107,11 @@ AC_ARG_ENABLE([comparison-tool-reorg-tests],
[use_comparison_tool_reorg_tests=$enableval],
[use_comparison_tool_reorg_tests=no])
+AC_ARG_ENABLE([extended-rpc-tests],
+ AS_HELP_STRING([--enable-extended-rpc-tests],[enable expensive RPC tests when using lcov (default no)]),
+ [use_extended_rpc_tests=$enableval],
+ [use_extended_rpc_tests=no])
+
AC_ARG_WITH([qrencode],
[AS_HELP_STRING([--with-qrencode],
[enable QR code support (default is yes if qt is enabled and libqrencode is found)])],
@@ -341,6 +347,10 @@ else
AC_SUBST(COMPARISON_TOOL_REORG_TESTS, 0)
fi
+if test x$use_extended_rpc_tests != xno; then
+ AC_SUBST(EXTENDED_RPC_TESTS, -extended)
+fi
+
if test x$use_lcov = xyes; then
if test x$LCOV = x; then
AC_MSG_ERROR("lcov testing requested but lcov not found")
@@ -351,6 +361,9 @@ if test x$use_lcov = xyes; then
if test x$JAVA = x; then
AC_MSG_ERROR("lcov testing requested but java not found")
fi
+ if test x$PYTHON = x; then
+ AC_MSG_ERROR("lcov testing requested but python not found")
+ fi
if test x$GENHTML = x; then
AC_MSG_ERROR("lcov testing requested but genhtml not found")
fi