aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2018-07-27 17:25:09 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2018-07-28 19:34:36 +0000
commitafe087557747f640af90eaca8de8786dc226e56a (patch)
tree0770b3bc02f14cb221531f5a0d0c401e2583121c /configure.ac
parentd8ab8dc12db14cd206c61fb5d30a6a130160d9b9 (diff)
downloadbitcoin-afe087557747f640af90eaca8de8786dc226e56a.tar.xz
configure: Skip assembly support checks, when assembly is disabled
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 080082f316..11df27220e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -314,6 +314,8 @@ if test "x$CXXFLAGS_overridden" = "xno"; then
AX_CHECK_COMPILE_FLAG([-Wimplicit-fallthrough],[NOWARN_CXXFLAGS="$NOWARN_CXXFLAGS -Wno-implicit-fallthrough"],,[[$CXXFLAG_WERROR]])
fi
+if test "x$use_asm" = "xyes"; then
+
# Check for optional instruction set support. Enabling these does _not_ imply that all code will
# be compiled with them, rather that specific objects/libs may use them after checking for runtime
# compatibility.
@@ -391,6 +393,8 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
)
CXXFLAGS="$TEMP_CXXFLAGS"
+fi
+
CPPFLAGS="$CPPFLAGS -DHAVE_BUILD_INFO -D__STDC_FORMAT_MACROS"
AC_ARG_WITH([utils],