aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2020-08-11 11:59:33 +0200
committerMarcoFalke <falke.marco@gmail.com>2020-08-11 11:59:40 +0200
commit28a9df7d76a6bdd118cceacf31c5584325f45d8e (patch)
tree734d51160f8b86fd533330284424ea868a065dfd /configure.ac
parent05f5dd96c71e8d989c6f04771a3eab9d41f1ea49 (diff)
parentbe951470bea132b4cbe1823cd564bf14aaf0ea7e (diff)
downloadbitcoin-28a9df7d76a6bdd118cceacf31c5584325f45d8e.tar.xz
Merge #19025: [0.19] Backports
be951470bea132b4cbe1823cd564bf14aaf0ea7e Updated appveyor job to checkout a specific vcpkg commit ID. (Aaron Clauson) 1fd9cd2cb40a89a07de5b8b0bc870efe65a505d7 appveyor: Remove clcache (MarcoFalke) 8c0a9595ec81328a250dd1a79fcc3d2010db4d6d Remove cached directories and associated script blocks from appveyor CI configuration. (Aaron Clauson) d70f7000212b0050672452b762d92124f402eda6 lint: fix shellcheck URL in CI install (fanquake) f8f7d91b805928fe5a986e3dff6a9a73ac96e128 test: remove Cirrus CI FreeBSD job (fanquake) b7e16a82c99768494afb000dd19e308f306a89c3 Add missing QPainterPath include (Andrew Chow) 30a28146ac23aa3a9e510c5d6ab9a8d2c5b8177e gui: Avoid Wallet::GetBalance in WalletModel::pollBalanceChanged (João Barbosa) 0d87a5b4e2153a00e33474b56b48f0814c231697 QA: feature_segwit: Check that template "rules" includes "!segwit" as appropriate (Luke Dashjr) bde6a5a676e4de7c5133f61784a3239bb4a28f2e Bugfix: Include "csv","!segwit" in "rules" (Luke Dashjr) e422f65aee4b2a817b31bbd37c79d178570579df build: Set libevent minimum version to 2.0.21 (Hennadii Stepanov) 0d0dd6ae96c6e12226bba07994394ae78f7cddc6 Update with new Windows code signing certificate (Andrew Chow) Pull request description: Backports the following to the 0.19 branch: * #17946 - Fix GBT: Restore "!segwit" and "csv" to "rules" key * #18160 - gui: Avoid Wallet::GetBalance in WalletModel::pollBalanceChanged * #18425 - releases: Update with new Windows code signing certificate * #18676 - build: Check libevent minimum version in configure script * #19097 - qt: Add missing QPainterPath include (as per #19510) * #18640 - appveyor: Remove clcache * #19444 - test: Remove cached directories and associated script blocks from appveyor config * #19612 - lint: fix shellcheck URL in CI install * #18001 - Updated appveyor job to checkout a specific vcpkg commit ID Closes: #19510. ACKs for top commit: jnewbery: ACK be951470bea132b4cbe1823cd564bf14aaf0ea7e MarcoFalke: cherry-pick ACK be951470bea132b4cbe1823cd564bf14aaf0ea7e 🌎 Tree-SHA512: 2ec7e3ae1da99799ff6f8cfe26095d6885cffe6952b18a7e236dc5e657b3918225c2601b8c8e17cdff5319c40cb0a214d9fad49b0ff2f54af1db7c81d83a1df5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0e8a0813ad..ad6de55561 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1237,9 +1237,9 @@ if test x$use_pkgconfig = xyes; then
BITCOIN_QT_CHECK([PKG_CHECK_MODULES([QR], [libqrencode], [have_qrencode=yes], [have_qrencode=no])])
fi
if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests != xnononono; then
- PKG_CHECK_MODULES([EVENT], [libevent],, [AC_MSG_ERROR(libevent not found.)])
+ PKG_CHECK_MODULES([EVENT], [libevent >= 2.0.21],, [AC_MSG_ERROR(libevent version 2.0.21 or greater not found.)])
if test x$TARGET_OS != xwindows; then
- PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads],, [AC_MSG_ERROR(libevent_pthreads not found.)])
+ PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads >= 2.0.21],, [AC_MSG_ERROR(libevent_pthreads version 2.0.21 or greater not found.)])
fi
fi