aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSjors Provoost <sjors@sprovoost.nl>2019-01-29 18:59:12 +0100
committerSjors Provoost <sjors@sprovoost.nl>2019-01-30 11:31:15 +0100
commit0890339fb337de7690d501a5436657a9d996e5a7 (patch)
tree931ae4e7903bc206e5d05e7d8175605ef63d9dc1 /configure.ac
parent7275365c9bc7e7ebd6bbf7dcb251946aac44b5de (diff)
downloadbitcoin-0890339fb337de7690d501a5436657a9d996e5a7.tar.xz
build: prefer python3.4 even if newer versions are present on the system
Python 3.4 is the mimimum supported version according to doc/dependencies.md Systems with PyEnv ensure (via .python-version) that Python 3.4 is used for the functional tests. However make check calls bitcoin-util-test.py using the Python command found by configure.ac, which looks system wide. On systems with multiple versions of Python this would cause make check to fail, as it tries to call a version of Python that PyEnv blocks. This is solved by preferring python3.4 in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c4b1d63bfe..206e30b2d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,8 +84,8 @@ AC_PATH_TOOL(RANLIB, ranlib)
AC_PATH_TOOL(STRIP, strip)
AC_PATH_TOOL(GCOV, gcov)
AC_PATH_PROG(LCOV, lcov)
-dnl Python 3.x is supported from 3.4 on (see https://github.com/bitcoin/bitcoin/issues/7893)
-AC_PATH_PROGS([PYTHON], [python3.7 python3.6 python3.5 python3.4 python3 python])
+dnl Python 3.4 is specified in .python-version and should be used if available, see doc/dependencies.md
+AC_PATH_PROGS([PYTHON], [python3.4 python3.5 python3.6 python3.7 python3 python])
AC_PATH_PROG(GENHTML, genhtml)
AC_PATH_PROG([GIT], [git])
AC_PATH_PROG(CCACHE,ccache)