aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2018-06-15 13:39:12 -0400
committerCory Fields <cory-nospam-@coryfields.com>2018-06-15 13:40:07 -0400
commitd92204c900d55ebaf2af5c900162b3c2c8c296e2 (patch)
treed6c2ed3b29aaca8800540a8abee7a270a25e5d88 /configure.ac
parent466e16e0e8523909f9968c5823691b1d4a3d8175 (diff)
downloadbitcoin-d92204c900d55ebaf2af5c900162b3c2c8c296e2.tar.xz
build: add warning to detect hidden copies in range-for loops
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 926d0b8d00..71e4c97aba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -301,6 +301,7 @@ if test "x$CXXFLAGS_overridden" = "xno"; then
AX_CHECK_COMPILE_FLAG([-Wvla],[WARN_CXXFLAGS="$WARN_CXXFLAGS -Wvla"],,[[$CXXFLAG_WERROR]])
AX_CHECK_COMPILE_FLAG([-Wformat-security],[WARN_CXXFLAGS="$WARN_CXXFLAGS -Wformat-security"],,[[$CXXFLAG_WERROR]])
AX_CHECK_COMPILE_FLAG([-Wthread-safety-analysis],[WARN_CXXFLAGS="$WARN_CXXFLAGS -Wthread-safety-analysis"],,[[$CXXFLAG_WERROR]])
+ AX_CHECK_COMPILE_FLAG([-Wrange-loop-analysis],[WARN_CXXFLAGS="$WARN_CXXFLAGS -Wrange-loop-analysis"],,[[$CXXFLAG_WERROR]])
## Some compilers (gcc) ignore unknown -Wno-* options, but warn about all
## unknown options if any other warning is produced. Test the -Wfoo case, and