aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonas Schnelli <dev@jonasschnelli.ch>2016-11-14 10:55:56 +0100
committerJonas Schnelli <dev@jonasschnelli.ch>2016-11-16 12:02:05 +0100
commitd8274bcd00865d829808e8e05651c61dff7ccac0 (patch)
tree28c3d3c9b12f4f11456400ee7c8e0acf4865ccaa /configure.ac
parent87ab49e4fe38f0d8d527090ea348081037a68cef (diff)
downloadbitcoin-d8274bcd00865d829808e8e05651c61dff7ccac0.tar.xz
Add compile and link options echo to configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 705327e816..7ad4fe0ac4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1126,3 +1126,28 @@ case ${OS} in
mv qa/pull-tester/tests_config-2.py qa/pull-tester/tests_config.py
;;
esac
+
+echo
+echo "Options used to compile and link:"
+echo " with wallet = $enable_wallet"
+echo " with gui / qt = $bitcoin_enable_qt"
+if test x$bitcoin_enable_qt != xno; then
+ echo " qt version = $bitcoin_qt_got_major_vers"
+ echo " with qr = $use_qr"
+fi
+echo " with zmq = $use_zmq"
+echo " with test = $use_tests"
+echo " with bench = $use_bench"
+echo " with upnp = $use_upnp"
+echo " debug enabled = $enable_debug"
+echo
+echo " target os = $TARGET_OS"
+echo " build os = $BUILD_OS"
+echo
+echo " CC = $CC"
+echo " CFLAGS = $CFLAGS"
+echo " CPPFLAGS = $CPPFLAGS"
+echo " CXX = $CXX"
+echo " CXXFLAGS = $CXXFLAGS"
+echo " LDFLAGS = $LDFLAGS"
+echo